您的位置:首页 > 其它

Immediate Decodability(字典树-判断是否存在前缀)

2015-08-30 09:01 656 查看


Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2328 Accepted Submission(s): 1205



Problem Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that
each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:

A:01 B:10 C:0010 D:0000

but this one is not:

A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)



Input

Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing
a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).



Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.



Sample Input

01
10
0010
0000
9
01
10
010
0000
9




Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable




Source

Pacific Northwest 1998



#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
using namespace std;
char word[15][20];
struct Tree
{
    int num;//判断此节点是否为空的(就是一棵树的结束点)
    Tree *next[2];//这个是这棵树的子节点
    Tree()
    {
        num=0;
        for(int i=0;i<2;i++)
        {
            next[i]=NULL;
        }
    }//这是一棵树
}*root;//建立一个树根
void insert(Tree *p,char *s)
{
    int i=0;
    while(s[i])//当这个字符串的某一个元素不为空的时候
    {
        int x=s[i]-'0';//看这个元素在哪里?
        if(p->next[x]==NULL)//然后看这棵树有没有这个元素如果没有
        {
            p->next[x]=new Tree();//就在这棵树的此节点重新建立一棵子树
        }
        p=p->next[x];//p指向他的子树,这一点你就可以知道了所有字符串的元素原来他们都是主仆关系没有相同的等级关系!
        p->num++;
        i++;//继续遍历
    }
}//插入字符
int find(Tree *p,char *s)
{
    int i=0,ans=0;//寻找树的元素,ans是结果!
    while(s[i])//当他不为空的时候就是字符串还有的时候
    {
        int n=s[i]-'0';//找到他在这个树的节点
        if(p->next
)//如果节点不为空
        {
            p=p->next
;//p就指向该节点
            ans=p->num;//结果应该为1
            i++;
        }
        else
        {
            return 0;
        }
    }
    return ans;
}
int deltree(Tree* T)
{
    int i;
    if(T==NULL)
        return 0;
    for(i=0;i<2;i++)
    {
        if(T->next[i]!=NULL)
            deltree(T->next[i]);
    }
    free(T);
    return 0;
}
int main()
{
    int times=1,i=0,j,success=1;
    char s[20];
    root=new Tree();
    while(cin>>s)
    {
        if(strcmp(s,"9")==0)
        {
            for(j=0;j<i;j++)
            {
               // cout<<find(root,word[j])<<endl;
                if(find(root,word[j])>1)
                {
                    success=0;
                    break;
                }
            }
            if(success)
            {
                printf("Set %d is immediately decodable\n",times++);
            }
            else
            {
               printf("Set %d is not immediately decodable\n",times++);
            }
            deltree(root);
            root=new Tree();
            success=1;
            i=0;
        }
        else
        {
            strcpy(word[i],s);
            insert(root,word[i]);
            i++;
        }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: