您的位置:首页 > 其它

1074 -- 人见人爱A^B

2015-08-29 17:05 309 查看
人见人爱A^B
Time Limit:1000MS Memory Limit:65536K

Total Submit:109 Accepted:70
Description
求A^B的最后三位数表示的整数。

说明:A^B的含义是“A的B次方”

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。

Sample Input
2 3
12 6
6789 10000
0 0

Sample Output
8
984
1

Source
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1074 {
class Program {
static void Main(string[] args) {
string sb;
while ((sb = Console.ReadLine()) != null) {
string[] s = sb.Split();
int n = int.Parse(s[0]), m = int.Parse(s[1]);
if (n + m == 0) break;
int ans = 1;
for (int i = 1; i <= m; i++) {
ans *= n;
ans %= 1000;
}
Console.WriteLine(ans);
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: