您的位置:首页 > 其它

1073 -- Let the Balloon Rise

2015-08-29 17:04 351 查看
Let the Balloon Rise
Time Limit:1000MS Memory Limit:65536K

Total Submit:105 Accepted:67
Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will
count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N ( 0 < N < = 1000 ) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon
is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

Hint
输出出现次数最多的单词,次数相同则输出第一次出现的单词

Source
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace AK1073 {
class Program {
static void Main(string[] args) {
string sn;
while (!(sn = Console.ReadLine()).Equals("0")) {
int n = int.Parse(sn);
string[] s = new string[n + 5];
for (int i = 0 ; i < n ; i++)
s[i] = Console.ReadLine();
string axb = s[0];
Array.Sort(s , 0 , n);
int max = 1;
int count = 1;
int flag = 0;
for (int i = 0 ; i < n ; i++) {
count = 1;
for (int j = i + 1 ; j < n ; j++) {
if (s[j].Equals(s[i]))
count++;
else
break;
}
if (count > max) {
max = count;
flag = i;
}
}
if (max == 1)//??????????????????????????????????????????????????????????????
Console.WriteLine(axb);
else
Console.WriteLine(s[flag]);
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: