您的位置:首页 > 其它

1072 -- Sum Problem

2015-08-29 17:03 357 查看
Sum Problem
Time Limit:1000MS Memory Limit:65536K

Total Submit:504 Accepted:268
Description
Hey, welcome to ahstu oj.

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1
5050

Source
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1072 {
class Program {
static void Main(string[] args) {
string sb;
while ((sb = Console.ReadLine()) != null) {
long n = long.Parse(sb);
long sum = (1 + n) * n / 2;
Console.WriteLine(sum);
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: