您的位置:首页 > 其它

1006 -- 5个数求最值

2015-08-29 03:20 459 查看
5个数求最值
Time Limit:1000MS Memory Limit:65536K

Total Submit:786 Accepted:452
Description
Description:

设计一个从5个整数中取最小数和最大数的程序

Input

输入只有一组测试数据,为五个不大于1万的正整数

Output

输出两个数,第一个为这五个数中的最小值,第二个为这五个数中的最大值,两个数字以空格格开。

Sample Input
1 2 3 4 5

Sample Output
1 5

Source
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1006 {
class Program {
static void Main(string[] args) {
string[] s = Console.ReadLine().Split();
int min = 10000000, max = -10000000;
for (int i = 0; i < 5; i++) {
int temp = int.Parse(s[i]);
if (temp > max) max = temp;
if (temp < min) min = temp;
}
Console.WriteLine("{0} {1}", min, max);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: