您的位置:首页 > 产品设计 > UI/UE

1005 Number Sequence

2015-08-28 20:10 363 查看
Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5


Author

CHEN, Shunbao

Source

ZJCPC2004

找规律题,因为对7取余数,因此49必定是一个循环。也可以像如下代码一样,求出具体的循环的最短周期。

#include<iostream>
using namespace std;

int main()
{
int a[100],A,B,I,n;
a[1]=1;
a[2]=1;
while(cin>>A>>B>>n)
{
if(A==0&&B==0&&n==0)	break;
int cnt=0;
for(i=3;i<=99;i++)
{
a[i]=(A*a[i-1]+B*a[i-2])%7;
if(a[i]==1&&a[i-1]==1)	break;
if(a[i]==0&&a[i-1]==0) {cnt=1;break;}
}
if(cnt&&n>i-2){cout<<"0"<<endl;continue;}
i-=2;
n%=i;
if(n==0)n=i;
cout<<a
<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: