您的位置:首页 > 其它

[UVA1262]Password

2015-08-28 19:48 417 查看
Password

Description

Asterix, Obelix and their temporary buddies Suffix and Prefix has finally found the Harmony temple. However, its doors were firmly locked and even Obelix had no luck opening them.

A little later they found a string s, carved on a rock below the temple's gates. Asterix supposed that that's the password that opens the temple and read the string aloud. However, nothing happened. Then Asterix supposed that a password is some substring t of the string s.

Prefix supposed that the substring t is the beginning of the string s; Suffix supposed that the substring t should be the end of the string s; and Obelix supposed that t should be located somewhere inside the string s, that is, t is neither its beginning, nor its end.

Asterix chose the substring t so as to please all his companions. Besides, from all acceptable variants Asterix chose the longest one (as Asterix loves long strings). When Asterix read the substring t aloud, the temple doors opened.

You know the string s. Find the substring t or determine that such substring does not exist and all that's been written above is just a nice legend.

Input

You are given the string s whose length can vary from 1 to 106 (inclusive), consisting of small Latin letters.

Output

Print the string t. If a suitable t string does not exist, then print "Just a legend" without the quotes.

Sample Input

Input
fixprefixsuffix


Output
fix


Input
abcdabc


Output
Just a legend


Sample Output

Case 1: 13
Case 2: 6


Hint

找字符串中是否存在前后缀相同的字符串,KMP pre数组应用

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>

using namespace std;

const int maxn = 1000010;
int nb;
char b[maxn];
int pre[maxn];
int vis[maxn];

//b是模式串,a是目标串
void getpre(char *b, int *pre) {
int j, k;
pre[0] = -1;
j = 0;
k = -1;
while(j < nb) {
if(k == -1 || b[j] == b[k]) {
j++;
k++;
pre[j] = k;
}
else {
k = pre[k];
}
}
}

int main() {
// freopen("in", "r", stdin);
while(~scanf("%s", b)) {
memset(pre, 0, sizeof(pre));
memset(vis, 0, sizeof(vis));
nb = strlen(b);
if(nb < 3) {
printf("Just a legend\n");
continue;
}
getpre(b, pre);
for(int i = 0; i < nb; i++) {
vis[pre[i]] = 1;
}
int flag = 0;
while(pre[nb]) {
if(vis[pre[nb]]) {
printf("%.*s\n", pre[nb], b);
flag = 1;
break;
}
nb = pre[nb];
}
if(!flag) {
printf("Just a legend\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: