您的位置:首页 > 其它

hdoj 1050 Moving Tables

2015-08-28 09:57 405 查看

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24631 Accepted Submission(s): 8144



[align=left]Problem Description[/align]
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

[align=left]Input[/align]
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each
of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the
same manner as above.

[align=left]Output[/align]
The output should contain the minimum time in minutes to complete the moving, one per line.

[align=left]Sample Input[/align]

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


[align=left]Sample Output[/align]

10
20
30


思路:两个房间之间交换桌子,由于走廊窄,桌子大,走廊只能通过一张桌子,不会出现并排的桌子,问最少需要多长时间能把要求移动的桌子移动完。最少时间对应走廊共享(也可以理解为交叉)次数最多的那一段所用的时间。贪心,求最大重叠区间。别忘了判断前后两个房间的大小。因为房间是两侧的,所以要注意房间的奇偶性。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int cmp(int a,int b)
{
return a>b;
}
int main()
{
int T,n,i,j,s,t,temp;
int a[1000];
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
memset(a,0,sizeof(a));
for(i=1;i<=n;i++)
{
scanf("%d%d",&s,&t);
if(s>t)
{
temp=s;
s=t;
t=temp;
}
s=(s+1)/2;
t=(t+1)/2;
for(j=s;j<=t;j++)
{
a[j]++;
}
}
sort(a,a+1000,cmp);
printf("%d\n",a[0]*10);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: