您的位置:首页 > 其它

poj2398Toy Storage【判断直线与点位置关系+排序+二分查找】

2015-08-28 00:48 465 查看
 

Language:Default

[align=center]Toy Storage[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4633 Accepted: 2741
Description
Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply
throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 

Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 



We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The
coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and
(Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.
Output
For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number
of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output
Box
2: 5
Box
1: 4
2: 1


题意同poj2318给出的挡板没有排序按字典序输出装有i个玩具的格子的个数;注意排序方式

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
int ans[5010];
int pos[5010];
struct point{
int x,y;
};
struct Node{
point a,b;
}A[5010];
bool cmp(Node A,Node B) {
if (min(A.a.x,A.b.x)==min(B.a.x, A.b.x))
return max(A.a.x,A.b.x)<max(B.a.x,A.b.x);
return min(A.a.x,A.b.x)<min(B.a.x,A.b.x);
}
bool judge(int xx,int yy,int mid){
int ans=(A[mid].a.x-xx)*(A[mid].b.y-yy)-(A[mid].b.x-xx)*(A[mid].a.y-yy);
if(ans>0)return true;
return false;
}
void search(int xx,int yy,int n){
int left=0,right=n-1;
while(left<=right){
int mid=(left+right)>>1;
if(judge(xx,yy,mid))
left=mid+1;
else
right=mid-1;
}
pos[left]++;
}
int main()
{
int n,m,i,j,x1,y1,x2,y2;
while(scanf("%d",&n),n){
scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
for(i=0;i<n;++i){
int xu,xd;
scanf("%d%d",&xu,&xd);
A[i].a.x=xu;
A[i].a.y=y1;
A[i].b.x=xd;
A[i].b.y=y2;
}
sort(A,A+n,cmp);
memset(pos,0,sizeof(pos));
memset(ans,0,sizeof(ans));
for(i=0;i<m;++i){
int xx,yy;
scanf("%d%d",&xx,&yy);
search(xx,yy,n);
}
for (i=0;i<=n;i++)
ans[pos[i]]++;
printf ("Box\n");
for (i=1;i<=m;i++)
if (ans[i]!=0) {
printf("%d: %d\n",i,ans[i]);
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息