您的位置:首页 > 其它

1032. Sharing (25)

2015-08-27 16:21 211 查看
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we maylet the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored asshowed in Figure 1.



Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total
number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1


提交代

——————————

简单题目,题目和以前一道题很像,在leetcode上面也有类似的题目,比这个的限制更高。
http://blog.csdn.net/xkzju2010/article/details/45766635
#include <iostream>
#include <vector>
#include <map>
#include <set>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

struct node{
int address;
char data;
int next;
}*p1,*p2;
int s1,s2,n;
vector<node> vnode(100010);
vector<node> v1;
vector<node> v2;

vector<node> build(int s, vector<node> v){
int ne=s;
vector<node> vv;
while(ne!=-1){
vv.push_back(v[ne]);
ne=v[ne].next;
}
return vv;
}

int main(int argc, char** argv) {
//	map<int,int> map;
int res=-1;
scanf("%d %d %d",&s1,&s2,&n);
//	v.resize(n);
for(int i=0; i<n; i++){
node tmp;
scanf("%d %c %d",&tmp.address,&tmp.data,&tmp.next);
vnode[tmp.address]=tmp;
}
v1=build(s1,vnode);
v2.clear();
v2=build(s2,vnode);

set<int> set;
for(int i=0; i<v1.size(); i++){
set.insert(v1[i].address);
}
std::set<int>::iterator it;
for(int i=0; i<v2.size();i++){
it=set.find(v2[i].address);
if(it!=set.end()){
res=v2[i].address;
break;
}
}
res==-1?printf("-1\n"):printf("%05d\n",res);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: