您的位置:首页 > 其它

HDU 1597 数学题

2015-08-27 13:37 225 查看


find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9550    Accepted Submission(s): 2767


Problem Description

假设:

S1 = 1

S2 = 12

S3 = 123

S4 = 1234

.........

S9 = 123456789

S10 = 1234567891

S11 = 12345678912

............

S18 = 123456789123456789

..................

现在我们把所有的串连接起来

S = 1121231234.......123456789123456789112345678912.........

那么你能告诉我在S串中的第N个数字是多少吗?

 

Input

输入首先是一个数字K,代表有K次询问。

接下来的K行每行有一个整数N(1 <= N < 2^31)。

 

Output

对于每个N,输出S中第N个对应的数字.

 

Sample Input

6
1
2
3
4
5
10

 

Sample Output

1
1
2
1
2
4
找规律
#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int t=0;
scanf("%d",&t);
while(t--)
{
double n=0,m=0;
long long int x=0,x1=0,y=0;
scanf("%lf",&m);
n=sqrt(2*m+1.0/4)-1.0/2;
x=n;
x1=x*(x+1)/2;
y=m;
if(y-x1==0)
{
if(x%9==0)
x=9;
else
x%=9;
printf("%lld\n",x);
}
else
{
if((y-x1)%9==0)
printf("9\n");
else
printf("%lld\n",(y-x1)%9);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: