您的位置:首页 > 产品设计 > UI/UE

POJ 2371 Questions and answers(水~)

2015-08-27 09:40 633 查看
Description

首先给出一个n,一下n行接着给n个数,然后是一个m,接着是m行查询,要问这n个数从小到大的第i个数是多少(1<=n<=100000,1<=k<=100)

Input

第一行为一个整数n表示数列长度,之后n行为n个数,然后用一行###隔开,之后是一个整数m表示查询次数,然后是m个数表示查询

Output

对于每次查询,输出数列中第i小的数

Sample Input

5

7

121

123

7

121

###

4

3

3

2

5

Sample Output

121

121

7

123

Solution

水题

Code

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF (1<<29)
#define maxn 100005
int num[maxn];
int n,m;
int main()
{
char s[10];
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&num[i]);
sort(num,num+n);
scanf("%s",s);
scanf("%d",&m);
while(m--)
{
int d;
scanf("%d",&d);
printf("%d\n",num[d-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: