您的位置:首页 > 其它

USACO-Section 1.3 Ski Course Design(枚举)

2015-08-26 23:55 239 查看
Ski Course Design

Farmer John has N hills on his farm (1 <= N <= 1,000), each with an integer elevation in the range 0 .. 100. In the winter, since there is abundant snow on these hills, FJ routinely operates a ski training camp.
Unfortunately, FJ has just found out about a new tax that will be assessed next year on farms used as ski training camps. Upon careful reading of the law, however, he discovers that the official definition of a
ski camp requires the difference between the highest and lowest hill on his property to be strictly larger than 17. Therefore, if he shortens his tallest hills and adds mass to increase the height of his shorter hills, FJ can avoid paying the tax as long as
the new difference between the highest and lowest hill is at most 17.
If it costs x^2 units of money to change the height of a hill by x units, what is the minimum amount of money FJ will need to pay? FJ can change the height of a hill only once, so the total cost for each hill is
the square of the difference between its original and final height. FJ is only willing to change the height of each hill by an integer amount.

PROGRAM NAME: skidesign

INPUT FORMAT:

Line 1:The integer N.
Lines 2..1+N:Each line contains the elevation of a single hill.

SAMPLE INPUT (file skidesign.in):

5
20
4
1
24
21

INPUT DETAILS:

FJ's farm has 5 hills, with elevations 1, 4, 20, 21, and 24.

OUTPUT FORMAT:

The minimum amount FJ needs to pay to modify the elevations of his hills so the difference between largest and smallest is at most 17 units.
Line 1:

SAMPLE OUTPUT (file skidesign.out):

18

OUTPUT DETAILS:

FJ keeps the hills of heights 4, 20, and 21 as they are. He adds mass to the hill of height 1, bringing it to height 4 (cost = 3^2 = 9). He shortens the hill of height 24 to height 21, also at a cost of 3^2 = 9.

思路:数据很小,直接枚举山的最高高度即可,对于山的最高高度i,若i-h[j]>17,则将h[j]的高度调整为i-17;若h[j]>i,则将h[j]的高度调整为i;求出所有最高高度的方案的调整费用的最小值。

/*
ID: your_id_here
PROG: skidesign
LANG: C++
*/
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int h[1005],ans,minh,maxh,tmp,t;

int main() {
int i,j,n;
freopen("skidesign.in","r",stdin);
freopen("skidesign.out","w",stdout);
while(1==scanf("%d",&n)) {
maxh=0,minh=100;
for(i=0;i<n;++i) {
scanf("%d",h+i);
maxh=max(maxh,h[i]);//求山的最高高度
minh=min(minh,h[i]);//求山的最低高度
}
ans=0x3f3f3f3f;
for(i=minh+17;i<=maxh;++i) {//枚举山的最高高度
tmp=0;
for(j=0;j<n;++j) {
if((t=i-h[j]-17)>0)//如果此山的高度小于  最高高度-17,将其调整至  最高高度-17
tmp+=t*t;
else if((t=h[j]-i)>0)//如果此山的高度大于最高高度,将其调整至最高高度
tmp+=t*t;
}
ans=min(ans,tmp);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: