您的位置:首页 > 其它

POJ 1651 Multiplication Puzzle (区间DP)

2015-08-26 21:25 211 查看
题目链接

Description
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the
card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5

Sample Output
3650

题意:

输入:第一行一个n代表有n个数;

第二行有n个数;

输出:从中取一个数a[i]得到的值是a[i]和旁边两个数的乘积(因为取过的数就消失了),最左边和最右边那个数不能取,问你把中间的数全部取完最后剩两个数(最左边和最右边两个数)所能得到的最小值。

分析:典型的区间DP,我们用dp[i][j]表示区间[i,j]内所能得到的最小值,当然由于边上两个数不能取,所以在[2,n-1]区间内操作就行,最后的结果为dp[2][n-1],转移方程为:dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[k]*a[i-1]*a[j+1]),其中i<=k<=j,表示在区间[i,j]内最后取k位置这个数,由于此区间其他位置都已经取完了,所以就要乘上a[i-1]和a[j+1]。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x7FFFFFFF
#define ll long long
using namespace std;
ll dp[102][102],a[102];
int main()
{
ll n;
while(~scanf("%lld",&n))
{
for(ll i=1;i<=n;i++)
scanf("%lld",&a[i]);
for(ll i=1;i<=n;i++)
for(ll j=1;j<=n;j++)
if(j>=i) dp[i][j]=inf;
else dp[i][j]=0;
for(ll i=2;i<n;i++) dp[i][i]=a[i-1]*a[i]*a[i+1];
for(ll l=1;l<=n;l++)
{
for(ll i=2;i+l<n;i++)
{
ll j=i+l;
for(ll k=i;k<=j;k++)
{
dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[k]*a[i-1]*a[j+1]);
}
}
}
printf("%lld\n",dp[2][n-1]);
}
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: