您的位置:首页 > 其它

poj3009 Curling 2.0 (DFS按直线算步骤)

2015-08-26 20:59 471 查看
Curling 2.0

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14563Accepted: 6080
Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.

The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.

When
the stone stands still, you can make it moving by throwing it. You may
throw it to any direction unless it is blocked immediately(Fig. 2(a)).

Once thrown, the stone keeps moving to the same direction until one of the following occurs:

The stone hits a block (Fig. 2(b), (c)).

The stone stops at the square next to the block it hit.

The block disappears.

The stone gets out of the board.

The game ends in failure.

The stone reaches the goal square.

The stone stops there and the game ends in success.

You
cannot throw the stone more than 10 times in a game. If the stone does
not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements

Under
the rules, we would like to know whether the stone at the start can
reach the goal and, if yes, the minimum number of moves required.

With
the initial configuration shown in Fig. 1, 4 moves are required to
bring the stone from the start to the goal. The route is shown in Fig.
3(a). Notice when the stone reaches the goal, the board configuration
has changed as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The
input is a sequence of datasets. The end of the input is indicated by a
line containing two zeros separated by a space. The number of datasets
never exceeds 100.

Each dataset is formatted as follows.


the width(=w) and the height(=h) of the board
First row of the board
...
h-th row of the board


The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.


0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:


6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1



Output

For
each dataset, print a line having a decimal integer indicating the
minimum number of moves along a route from the start to the goal. If
there are no such routes, print -1 instead. Each line should not have
any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source

Japan 2006 Domestic

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int map[25][25];
int n,m;
int sx,sy,ex,ey;
int nex[4][2]={1,0,0,1,0,-1,-1,0};
int ans,step;

bool judge(int x,int y){
if(x>=0&&x<n&&y>=0&&y<m&&map[x][y]!=1)
return true;
return false;
}

void dfs(int x,int y){
if(step>10)
return;
for(int i=0;i<4;i++){
int tx=x+nex[i][0];
int ty=y+nex[i][1];
bool flag=false;
while(judge(tx,ty)){
flag=true;
if(tx==ex&&ty==ey&&step<ans)
ans=step;
tx+=nex[i][0];
ty+=nex[i][1];
}
if(map[tx][ty]==1&&flag){
step++;
map[tx][ty]=0;
dfs(tx-nex[i][0],ty-nex[i][1]);
step--;
map[tx][ty]=1;
}

}

}

int main(){
while(scanf("%d%d",&m,&n)!=EOF){
memset(map,0,sizeof(map));
if(n==0&&m==0)
break;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
scanf("%d",&map[i][j]);
if(map[i][j]==2)
sx=i,sy=j;
if(map[i][j]==3)
ex=i,ey=j;
}
}
ans=100000;
step=1;
dfs(sx,sy);
if(ans>10)
printf("-1\n");
else
printf("%d\n",ans);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: