您的位置:首页 > 其它

Proud Merchants

2015-08-26 19:39 309 查看

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 3593 Accepted Submission(s): 1500



[align=left]Problem Description[/align]
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any
more.

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.

If he had M units of money, what’s the maximum value iSea could get?

[align=left]Input[/align]
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

[align=left]Output[/align]
For each test case, output one integer, indicating maximum value iSea could get.

[align=left]Sample Input[/align]

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3


[align=left]Sample Output[/align]

5
11


[align=left]Author[/align]
iSea @ WHU

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[5100];
struct node
{
int p,q,v;
}edge[5100];
bool cmp(node s1,node s2)
{
return s1.p-s1.q>s2.p-s2.q;//虽然不知道为神魔,但是要对p-q排序
}
int main()
{
int m,n;
while(scanf("%d%d",&m,&n)!=EOF)
{
int i,j,k;
memset(f,0,sizeof(f));
memset(edge,0,sizeof(edge));
for(i=0;i<m;i++)
scanf("%d%d%d",&edge[i].p,&edge[i].q,&edge[i].v);
sort(edge,edge+m,cmp);
for(i=0;i<m;i++)
{
for(j=n;j>=edge[i].q;j--)
{
f[j]=max(f[j],f[j-edge[i].p]+edge[i].v);
}
}
printf("%d\n",f
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: