您的位置:首页 > 其它

【POJ3468】【线段树成段更新】

2015-08-26 19:00 405 查看
A Simple Problem with Integers

Time Limit: 5000MSMemory Limit: 131072K
Total Submissions: 78730Accepted: 24266
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is
to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output
4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly--2007.11.25, Yang Yi

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back
#define lson l,m,rt<<1
#define rson m,r,rt<<1|1
typedef long long ll;

int n,m;
const int MAXN = 100010;
ll sum[MAXN*4];
ll add[MAXN*4];

void PushUp(int rt)
{
	sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void PushDown(int rt,int l1,int l2)
{
	if(add[rt])
	{
		add[rt<<1] += add[rt];
		sum[rt<<1] += add[rt] * l1;
		add[rt<<1|1] += add[rt];
		sum[rt<<1|1] += add[rt] * l2;
		add[rt] = 0;
	}
}

void build(int l,int r,int rt)
{
	add[rt] = 0;
	if(r - l == 1)
	{
		scanf("%I64d",&sum[rt]);
		return ;
	}

	int m = (l + r) >> 1;
	build(lson);
	build(rson);

	PushUp(rt);
}

void update(int L,int R,int v,int l,int r,int rt)
{
	if(L<= l && r <= R)
	{
		add[rt] += v;
		<span style="background-color: rgb(255, 255, 153);">sum[rt] += (r - l) * v;</span>
		return;
	}

	

	int m = (l + r) >> 1;
	PushDown(rt,m-l,r-m);
	if(L <= m-1) update(L,R,v,lson);
	if(m <= R-1) update(L,R,v,rson);

	PushUp(rt);
}

ll query(int L,int R,int l,int r,int rt)
{
	if(L <= l && r <= R)
	{
		return sum[rt];
	}

	

	int m = (l + r) >> 1;
	PushDown(rt,m-l,r-m);
	ll ret = 0;
	if(L <= m-1) ret += query(L,R,lson);
	if(m <= R-1) ret += query(L,R,rson);
	return ret;
}

char str[2];
int main()
{
	freopen("in.txt","r",stdin);
	while(scanf("%d%d",&n,&m) != EOF)
	{
		build(1,n+1,1);
		for(int i=0;i<m;i++)
		{
			scanf("%s",str);
			if(str[0] == 'Q')
			{
				int l,r;
				scanf("%d%d",&l,&r);
				printf("%I64d\n",query(l,r+1,1,n+1,1));
			}
			else
			{
				int l,r,a;
				scanf("%d%d%d",&l,&r,&a);
				<span style="background-color: rgb(255, 255, 102);">update(l,r+1,a,1,n+1,1);</span>
			}
		}
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: