您的位置:首页 > 其它

hdu1020

2015-08-26 17:48 513 查看

Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 33303 Accepted Submission(s): 14811



Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC


Sample Output
ABC
A2B3C


Author
ZHANG Zheng

#include <stdio.h>
#include <string.h>
main ()
{
    int n;
    char str[10005];
    int i,j,len,t;
    scanf ("%d",&n);
    while (n--)
    {
        scanf ("%s",str);
        len=strlen(str);
        t=1;
        for (i=0;i<len;i++)
        {
            if (str[i]==str[i+1])
                t++;
            if (str[i]!=str[i+1])
            {
                if (t!=1)
                {
                    printf ("%d%c",t,str[i]);
                    t=1;
                }
                else
                {
                    printf ("%c",str[i]);
                    t=1;
                }
            }    
        }
        printf ("\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: