您的位置:首页 > Web前端

hdoj 4009 Transfer water 【求无根树最小树形图】

2015-08-26 16:20 351 查看

Transfer water

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 4402 Accepted Submission(s): 1564



Problem Description

XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household.
If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one
which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar
should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the
c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.


Input

Multiple cases.

First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000).

Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000.

Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th
household.

If n=X=Y=Z=0, the input ends, and no output for that.



Output

One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line.



Sample Input

2 10 20 30
1 3 2
2 4 1
1 2
2 1 2
0 0 0 0




Sample Output

30

HintIn  3‐dimensional  space  Manhattan  distance  of  point  A  (x1,  y1,  z1)  and  B(x2,  y2,  z2)  is |x2‐x1|+|y2‐y1|+|z2‐z1|.




题意:一个村庄有N个家庭,他们都需要用水,已经给出每个家庭房子的坐标和高度。他们可以选择自己建水源(费用为房子高度乘以X),或者从有水源的村庄引一条渠道(费用为两者房子的曼哈顿距离乘以Y,若供应水源的家庭的房子高度低于得到水的家庭的房子高度,那么每修建一条水渠还需要额外的Z费用)。现在给你所有家庭自建水源后,可能引水的对象(有的家庭之间有矛盾,所以不会引水给对方)。问你需要的最少费用使得N个家庭都用上水,若不存在一种方案输出poor
XiaoA。


思路:建立虚根N,连接所有家庭, 边权为他们自建水源的费用。所有家庭向他们可能引水的对象建边, 边权为引渠道的费用,然后跑一遍朱刘算法就ok了。

朱刘算法要注意自环的处理,虽然这道题不处理也能过。

AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#define MAXN 1010
#define MAXM 1000000+1010
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
struct Node
{
    int x, y, h;
};
Node num[MAXN];
struct Edge
{
    int from, to, cost;
};
Edge edge[MAXM];
int edgenum;//边数
int pre[MAXN], in[MAXN];;
int vis[MAXN], id[MAXN];
int N, X, Y, Z;
int dis(Node a, Node b)//曼哈顿距离
{
    return abs(a.x - b.x) + abs(a.y - b.y) + abs(a.h - b.h);
}
void addEdge(int u, int v, int w)
{
    Edge E = {u, v, w};
    edge[edgenum++] = E;
}
void getMap()
{
    edgenum = 0;
    for(int i = 0; i < N; i++)
        scanf("%d%d%d", &num[i].x, &num[i].y, &num[i].h),
        addEdge(N, i, num[i].h * X);//建立虚根N
    int k, y;
    for(int i = 0; i < N; i++)
    {
        scanf("%d", &k);
        while(k--)
        {
            scanf("%d", &y);
            y--;
            if(i == y) continue;//加上保险  防止自环
            int c = dis(num[i], num[y]) * Y;;
            if(num[i].h < num[y].h)
                c += Z;
            addEdge(i, y, c);
        }
    }
}
LL zhuliu(int root, int n, int m, Edge *edge)
{
    LL res = 0;
    int u, v;
    while(1)
    {
        for(int i = 0; i < n; ++i)
            in[i] = INF;
        for(int i = 0; i < m; i++)
        {
            Edge E = edge[i];
            if(E.from != E.to && E.cost < in[E.to])
            {
                pre[E.to] = E.from;
                in[E.to] = E.cost;
            }
        }
        for(int i = 0; i < n; i++)
            if(in[i] == INF && i != root)
                return -1;
        int tn = 0;
        memset(id, -1, sizeof(id));
        memset(vis, -1, sizeof(vis));
        in[root] = 0;
        for(int i = 0; i < n; i++)
        {
            res += in[i];
            v = i;
            while(vis[v] != i && id[v] == -1 && v != root)
            {
                vis[v] = i;
                v = pre[v];
            }
            while(id[v] == -1 && v != root)
            {
                for(u = pre[v]; u != v; u = pre[u])
                    id[u] = tn;
                id[v] = tn++;
            }
        }
        if(tn == 0) break;
        for(int i = 0; i < n; i++)
            if(id[i] == -1)
                id[i] = tn++;
        for(int i = 0; i < m; i++)
        {
            v = edge[i].to;
            edge[i].from = id[edge[i].from];
            edge[i].to = id[edge[i].to];
            if(edge[i].from != edge[i].to)
                edge[i].cost -= in[v];
        }
        n = tn;
        root = id[root];
    }
    return res;
}
int main()
{
    while(scanf("%d%d%d%d", &N, &X, &Y, &Z), N||X||Y||Z)
    {
        getMap();
        LL ans = zhuliu(N, N+1, edgenum, edge);
        if(ans == -1)
            printf("poor XiaoA\n");
        else
            printf("%lld\n", ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: