您的位置:首页 > 其它

Find them, Catch them - POJ 1703 种类并查集

2015-08-26 15:56 441 查看
Find them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 36663Accepted: 11249
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.


题意:一共有两个集团,D u v表示u和v不在同一集团,A u v 查询uv是否在同一集团。

思路:种类并查集,p[i]表示i的祖先,rank[i]=0表示i与其祖先是同一集合,rank[i]=1表示i与其祖先不是同一集合。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int T,t,n,m;
int p[100010],rank[100010];
char s[10];
int find(int x)
{
    int fx;
    if(x!=p[x])
    {
        fx=find(p[x]);
        rank[x]=(rank[x]+rank[p[x]])%2;
        p[x]=fx;
    }
    return p[x];
}
int main()
{
    int i,j,k,u,v,fu,fv;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
           p[i]=i;
        memset(rank,0,sizeof(rank));
        while(m--)
        {
            scanf("%s%d%d",s+1,&u,&v);
            fu=find(u);
            fv=find(v);
            if(s[1]=='D')
            {
                p[fv]=fu;
                rank[fv]=(rank[u]-rank[v]+1)%2;
            }
            else
            {
                if(fu==fv)
                {
                    k=(rank[u]-rank[v]+2)%2;
                    if(k==0)
                      printf("In the same gang.\n");
                    else
                      printf("In different gangs.\n");
                }
                else
                  printf("Not sure yet.\n");
            }
        }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: