您的位置:首页 > 其它

poj 1942 Paths on a Grid

2015-08-26 11:11 399 查看
j求 aCb 的值,  可以用 拆分阶乘,逐项相除,再乘以前面所有项之积
while(b > 0)
       sum *= (double)a--/(double)b--;

Description
Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2).
So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:



Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input
The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension.
Input is terminated by n=m=0.
Output
For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit
to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input
5 4
1 1
0 0

Sample Output
126
2

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#define RR freopen("in.txt","r",stdin)
#define WW freopen("out.txt","w",stdin)
#define LL long long
#define INF 0x3f3f3f3f
#define MAX 33000
using namespace std;

int main()
{
unsigned  m,n;
while(cin>>n>>m && (n||m))
{
double sum = 1.0;
unsigned a = m+n;
unsigned b = m > n ? n : m;
while(b > 0)
{
sum *= ((double)a--)/((double)b--);
}
printf("%.0f\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: