您的位置:首页 > 其它

【POJ2421】【最小生成树水题】【prim】

2015-08-26 10:03 411 查看
Language:
Default

Constructing Roads

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 20991Accepted: 8869
Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

Source

PKU Monthly,kicc
[Submit] [Go Back] [Status]
[Discuss]

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back
int n,m;
int g[110][110];
bool in[110];
int main()
{
    while(scanf("%d",&n)!=EOF)
	{
		memset(in,0,sizeof(in));
		int ret = 0;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&g[i][j]);
			}
		}

		scanf("%d",&m);
		for(int i=0;i<m;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			g[u][v] = 0;
			g[v][u] = 0;
		}
		in[1] = true;
		for(int i=0;i<n-1;i++)
		{
			int mins = 0x3f3f3f3f;
			int p = -1;
			for(int j=1;j<=n;j++)
			{
				for(int k=1;k<=n;k++)
				{
					if(in[j] && !in[k])
					{
						if(g[j][k] < mins)
						{
							mins = g[j][k];
							p = k;
						}
					}
				}
			}
			in[p] = true;
			ret += mins;
		} 

		printf("%d\n",ret);
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: