您的位置:首页 > 其它

poj 1562 DFS+枚举

2015-08-25 15:38 246 查看
Oil Deposits

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 14611Accepted: 7961
Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square
plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be
quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and
1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

Source //DFS主要是用于全部遍历方面, 用BFS求最小值比较好.
Mid-Central USA 1997

题意叫求有几个连续的大油田



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#define INF 0x3f3f3f3f

using namespace std;

int n,m;
char a[200][200];
int dx[]={-1,0,1,0,-1,-1,1,1};
int dy[]={0,-1,0,1,1,-1,-1,1};
int panduan(int x,int y)
{
if(x<n&&y<m&&x>=0&&y>=0&&a[x][y]=='@')
return 1;
return 0;
}
int DFS(int x,int y)
{
if(!panduan(x,y))
return 0;
a[x][y]='*';    //将走过的点全部的变为非油田.
for(int i=0;i<8;i++)
{
int fx=dx[i]+x;
int fy=dy[i]+y;
if(panduan(fx,fy))
DFS(fx,fy);
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(!n&&!m)  break;
for(int i=0;i<n;i++)
{
scanf("%s",a[i]);
}
int num=0;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
if(a[i][j]=='@')//看有几个连续的部分
{
DFS(i,j);
num++;
}
}
printf("%d\n",num);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: