您的位置:首页 > 其它

Y2K Accounting Bug POJ 2586

2015-08-25 14:48 357 查看
Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input
Input is a sequence of lines, each containing two positive integers s and d.
Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000

Sample Output
116
28
300612
Deficit

Source
Waterloo local 2000.01.29

大体题意:有一个公司由于某个病毒使公司赢亏数据丢失,但该公司每月的 赢亏是一个定数,要么一个月赢利s,要么一月亏d。现在ACM只知道该公司每五个月有一个赢亏报表,而且每次报表赢利情况都为亏。在一年中这样的报表总共有8次(1到5,2到6,…,8到12),现在要编一个程序确定当赢s和亏d给出,并满足每张报表为亏的情况下,全年公司最高可赢利多少,若存在,则输出多多额,若不存在,输出"Deficit"。

分析:

他的要求是盈利最高,只看前五个月的话:最好的情况就是只有第五个月亏损(贪心思想),而且第五个月的亏损要大于前四个月的和,如果不大于,那就退一步,第四,五两个月的亏损的和大于前三个月的,依次类推当前四个月的亏损都不大于第一个月的盈利的时候,输出Deficit.

代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>

using namespace std;
int main()
{
int n,m;
while(cin>>n>>m)
{
int ans=0;
if(m>4*n)ans=10*n-2*m;
else if(2*m>3*n)ans=8*n-4*m;
else if(3*m>2*n)ans=6*(n-m);
else  if(4*m>n)ans=3*(n-3*m);
else ans=-1;
if(ans<0)
{
cout<<"Deficit"<<endl;
}
else
{
cout<<ans<<endl;
}
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: