您的位置:首页 > 其它

POJ 1456 Supermarket(贪心 + 并查集 )

2015-08-25 11:07 543 查看
题意:一开始题意理解错了WA,WA,WA,我理解成一个物品只能在其标出的d时间销售了,其实是可以是1-d这个时间段售出,求最大利润。

解题思路:自己脑卡,看别人的看会。

分析:应该最先安排利润最高的产品如何进行销售,而且每个时间点只能有一个物品售出。先按高利润排序, 用并查集查出它时间最后期限,优先安排其时间尽可能靠后,然后用并查集将时间期限往前提一天,因为时间期限相同的物品有很多,利润有不同,这样贪心出来保证是最优解。

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time
for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is
Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts
at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.



Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product.
White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10


Sample Output

80
185


Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

时间奇快:

Memory: 840 KBTime: 16 MS
Language: G++Result: Accepted
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define FOR(i, s, t) for(int i = (s) ; i <= (t) ; ++i)
#define REP(i, n) for(int i = 0 ; i < (n) ; ++i)

int buf[10];
inline long long read()
{
    long long x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}

inline void writenum(int i)
{
    int p = 0;
    if(i == 0) p++;
    else while(i)
        {
            buf[p++] = i % 10;
            i /= 10;
        }
    for(int j = p - 1 ; j >= 0 ; --j) putchar('0' + buf[j]);
}
/**************************************************************/
#define MAX_N 10005
const int INF = 0x3f3f3f3f;
int parent[MAX_N];

int find(int a)
{
    if(parent[a] != a)
    {
        parent[a] = find(parent[a]);
    }
    return parent[a];
}

struct node
{
    int p, d;
} a[MAX_N];

bool cmp(node a, node b)
{
    return a.p > b.p;
}

inline void init(int n)
{
    for(int i = 0 ; i < n + 5 ; i++)
    {
        parent[i] = i;
    }
}

int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        int maxtime = -INF;
        for(int i = 0 ; i < n ; i++)
        {
            a[i].p = read();
            a[i].d = read();
            if(maxtime < a[i].d) maxtime = a[i].d;
        }
        init(maxtime);
        sort(a, a + n, cmp);
        int ans = 0;
        for(int i = 0 ; i < n ; i++)
        {
            int d = find(a[i].d);
//            cout<<a[i].p<<" "<<d<<endl;
            if(d >= 1)
            {
//                cout<<a[i].p<<" "<<a[i].d<<endl;
                ans += a[i].p;
                parent[d] = d - 1;
            }
        }
        cout<<ans<<endl;
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: