您的位置:首页 > 其它

[POJ2001]Shortest Prefixes

2015-08-25 00:16 295 查看
题目链接:http://poj.org/problem?id=2001

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

这个题…真是「哔」了大野狗了,不应该卡这么久的。哎,卡在了下面注释的地方,好歹今天做出来了,否则该睡不了觉了。我可真是水啊……

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>

using namespace std;

char str[1010][25];
typedef struct Node {
Node *next[26];
int cnt;
Node() {
cnt = 0;
for(int i = 0; i < 26; i++) {
next[i] = NULL;
}
}
}Node;

void insert(Node *p, char *str) {
int len = strlen(str);
for(int i = 0; i < len; i++) {
int t = str[i] - 'a';
if(p->next[t] == NULL) {
p->next[t] = new Node();
}
p = p->next[t];
p->cnt++;
}
}

int find(Node *p, char *str) {
for(int i = 0; str[i]; i++) {
int t = str[i] - 'a';
p = p->next[t];
printf("%c", str[i]);
if(p->cnt == 1) {   //就是这里
break;
}
}
}

int main() {
int n = 0;
Node *root = new Node();
// freopen("D.in", "r", stdin);
while(gets(str
) && strlen(str
)) {
insert(root, str
);
n++;
}
for(int i = 0; i < n; i++) {
printf("%s ", str[i]);
find(root, str[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: