您的位置:首页 > 其它

The Euler function(hdoj --2824-欧拉函数)

2015-08-24 20:17 387 查看

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4518    Accepted Submission(s): 1879


[align=left]Problem Description[/align]
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very
easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

[align=left]Input[/align]
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

[align=left]Output[/align]
Output the result of (a)+ (a+1)+....+ (b)
 

[align=left]Sample Input[/align]

3 100

 

[align=left]Sample Output[/align]

3042

 

[align=left]Source[/align]
2009 Multi-University Training Contest 1 - Host by TJU

 

[align=left]Recommend[/align]
gaojie   |   We have carefully selected several similar problems for you:  2818 2825 2817 2822 2821

解析:(转)
定义:对于正整数n,φ(n)是小于或等于n的正整数中,与n互质的数的数目。
    例如:φ(8)=4,因为1,3,5,7均和8互质。
性质:1.若p是质数,φ(p)=
p-1.
   2.若n是质数p的k次幂,φ(n)=(p-1)*p^(k-1)。因为除了p的倍数都与n互质
   3.欧拉函数是积性函数,若m,n互质,φ(mn)=
φ(m)φ(n).

  根据这3条性质我们就可以推出一个整数的欧拉函数的公式。因为一个数总可以写成一些质数的乘积的形式。

  E(k)=(p1-1)(p2-1)...(pi-1)*(p1^(a1-1))(p2^(a2-1))...(pi^(ai-1))
    = k*(p1-1)(p2-1)...(pi-1)/(p1*p2*...*pi)
    = k*(1-1/p1)*(1-1/p2)...(1-1/pk)
在程序中利用欧拉函数如下性质,可以快速求出欧拉函数的值(a为N的质因素)
  若( N%a
==0&&(N/a)%a
==0)则有:E(N)=
E(N/a)*a;
  若( N%a
==0&&(N/a)%a
!=0)则有:E(N)=
E(N/a)*(a-1);
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=3000010;
int prime
,isprime
;
int phi
;
void get_phi()
{
int i,j,cnt=0;
for(i=2;i<N;i++)
{
if(isprime[i]==0)
{
prime[cnt++]=i;
phi[i]=i-1;
}
for(j=0;j<cnt && i*prime[j]<N;j++)
{     //注意这里,i*prime[j]<N 可换成 prime[j]<=N/i(带等号)
isprime[i*prime[j]]=1;
if(i%prime[j]==0)
phi[i*prime[j]]=phi[i]*prime[j];
else
phi[i*prime[j]]=phi[i]*(prime[j]-1);
}
}
}
int main()
{
long long sum;
int a,b;
get_phi();
while(~scanf("%d%d",&a,&b))
{
sum=0;
for(int i=a;i<=b;i++)
sum+=phi[i];
cout<<sum<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: