您的位置:首页 > 其它

Binary Tree SDUT 2499

2015-08-24 20:07 375 查看
Description
Background

Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:

The root contains the pair (1, 1).

If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem

Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right
child?
Input
The first line contains the number of scenarios.

Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent

a node (i, j). You can assume that this is a valid node in the binary tree described above.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how
often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.
Sample Input
3
42 1
3 4
17 73

Sample Output
Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6


首先看到数据范围是20亿,如果用减法必定会TLE,减法和除法差不多,用除法的话就不会TLE了。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

int main()
{
int t,a,b;
cin>>t;
int i=1;
while(t--)
{
cin>>a>>b;

int l=0,r=0;
while(a!=1||b!=1)
{
int cnt=0;
if(a>b)
{
cnt=(a-1)/b;避免除尽出现0的情况,因为它的最终结果是到1。
l+=cnt;
a-=b*cnt;
}
else
{
cnt=(b-1)/a;//同上
r+=cnt;
b-=a*cnt;
}
}
printf("Scenario #%d:\n%d %d\n\n",i++,l,r);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: