您的位置:首页 > 其它

Billboard 线段树更新叶子节点

2015-08-24 19:50 253 查看

Billboard

在大学门口,有一个高位h 宽为w的广告牌,现在广告牌是空的,有一些小的广告要张贴到广告牌上,已知这些小广告的高度都是1,宽为wi,张贴有一定规律,按照顺序来,并且往最高处贴,如果最高处贴不开就往下一行贴,输出每一张广告贴在的行,若果广告牌上贴不开,就输出-1

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions,
changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.


Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.


Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement
can't be put on the billboard, output "-1" for this announcement.


Sample Input
3 5 5
2
4
3
3
3




Sample Output
1
2
1
3
-1


题意:h*w的木板,放进一些1*L的物品,求每次放空间能容纳且最上边的位子

思路:每次找到最大值的位子,然后减去L

线段树功能:query:区间求最大值的位子(直接把update的操作在query里做了)

#include <cstdio>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn = 222222;
int h , w , n;
int MAX[maxn<<2];
void PushUP(int rt)
{
    MAX[rt] = max(MAX[rt<<1] , MAX[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    MAX[rt] = w;
    if (l == r) return ;
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
}
int query(int x,int l,int r,int rt)
{
    if (l == r)
    {
        MAX[rt] -= x;
        return l;
    }
    int m = (l + r) >> 1;
    int ret = (MAX[rt<<1] >= x) ? query(x , lson) : query(x , rson);
    PushUP(rt);
    return ret;
}
int main()
{
    while (~scanf("%d%d%d",&h,&w,&n))
    {
        if (h > n) h = n;
        build(1 , h , 1);
        while (n --)
        {
            int x;
            scanf("%d",&x);
            if (MAX[1] < x) puts("-1");
            else printf("%d\n",query(x , 1 , h , 1));
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: