您的位置:首页 > 其它

UVA 568 - Just the Facts

2015-08-24 19:02 363 查看
Description



The expression N!, read as `` N factorial," denotes the product of the first
N positive integers, where N is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800
For this problem, you are to write a program that can compute the last non-zero digit of any factorial for (


). For example, if your program is asked to compute the last nonzero digit of 5!, your program should
produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer
N, you should read the value and compute the last nonzero digit of N!.

Output

For each integer input, the program should print exactly one line of output. Each line of output should contain the value
N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``
-> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of
N!.

Sample Input

1
2
26
125
3125
9999

Sample Output

1 -> 1
2 -> 2
26 -> 4
125 -> 8
3125 -> 2
9999 -> 8


求n的阶层的最后一位不为0的数

每次不能单单只留最后一位数

因为可能下一位想成加起来能进一

所以要多保留几位

最少要保留五位数

#include <stdio.h>

int main(){
int n, temp;
while (scanf("%d", &n) != EOF) {
long long m = 1;
for (int i = 1; i <= n; i++) {
temp = i;
while (temp % 10 == 0)
temp /= 10;
m *= temp;
while (m % 10 == 0)
m /= 10;
m = m % 100000;
}
printf("%5d -> %lld\n", n, m % 10);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: