您的位置:首页 > 其它

hdoj 3665 Seaside

2015-08-24 16:01 344 查看

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1375 Accepted Submission(s): 990



[align=left]Problem Description[/align]
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed
that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

[align=left]Input[/align]
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines
followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that
the distance between the i-th town and the SMi town is LMi.

[align=left]Output[/align]
Each case takes one line, print the shortest length that XiaoY reach seaside.

[align=left]Sample Input[/align]

5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1


[align=left]Sample Output[/align]

2
该题非常简单,关键是理解题意,该题的题意是XiaoY 想去海边,让你帮忙找最近的路,XiaoY 所在的城镇用零表示,先输入一个数表示城镇的个数,然后输入一组数第一个表示0号城镇有多少条路,第二个数表示城镇是否靠海,靠海1,不0;同理以此输入,最终计算出结果
#include<stdio.h>
#include<string.h>
#define INL 0x3f3f3f
int dist[30][30],vid[49];
void floyd(int n)
{
int i,j,k;
for(k=0;k<n;k++)
for(i=0;i<n;i++)
for(j=0;j<n;j++)
if(dist[i][j]>dist[i][k]+dist[k][j])
dist[i][j]=dist[i][k]+dist[k][j];
}
int main()
{
int n,a,b,c,d;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
if(i==j)
dist[i][j]=0;
else dist[i][j]=INL;
}
for(int i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
vid[i]=b;
for(int j=0;j<a;j++)
{
scanf("%d%d",&c,&d);
dist[i][c]=d;
}
}
floyd(n);
int min=INL;
for(int i=0;i<n;i++)
if(vid[i]&&min>dist[0][i])
min=dist[0][i];
printf("%d\n",min);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: