您的位置:首页 > 其它

HDU 1115 Lifting the Stone(多边形重心)

2015-08-24 15:24 411 查看


Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6464 Accepted Submission(s): 2682



Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly
and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly
to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.



Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed
by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the
neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.



Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal
point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.



Sample Input

2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11




Sample Output

0.00 0.00
6.00 6.00
给出n个点,按顺序连接得到一个多边形,求该多边形的重心n个点的多边形可分成n-2个三角形三角形的重心为 (x1+x2+x3)/3,(y1+y2+y3)/3把三角形的重心分别*三角形面积,求和结果/多边形面积即是最后结果
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <map>
#include <cmath>
#define N 1000001
#define eps 1e-6
#define PI acos(-1.0)
#define inf 0x3f3f3f3f
using namespace std;
struct Point
{
    double x, y;
}p
;
double cross(Point a, Point b)
{
    return a.x*b.y - a.y*b.x;
}
Point Interity(int n)
{
    Point ans;
    ans.x = 0;
    ans.y = 0;
    p
.x = p[0].x;
    p
.y = p[0].y;
    double area = 0;
    for(int i = 0; i < n; i++)
    {
        double t = cross(p[i], p[i+1]);
        ans.x += t * (p[i].x + p[i+1].x);
        ans.y += t * (p[i].y + p[i+1].y);
        area += t;
    }
    ans.x /= 3*area;
    ans.y /= 3*area;
    return ans;
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            scanf("%lf%lf", &p[i].x, &p[i].y);
        Point ans = Interity(n);
        printf("%.2lf %.2lf\n", ans.x, ans.y);
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: