您的位置:首页 > 其它

POJ 3468 A Simple Problem with Integers(区间更新+区间求和)

2015-08-24 15:23 239 查看
A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 78622 Accepted: 24231
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, ... ,
AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1,
A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa,
Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... ,
Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output
4
55
9
15

Hint
The sums may exceed the range of 32-bit integers.

ac代码:
#include<stdio.h>
struct s
{
int left;
int right;
__int64 sum;
__int64 lazy;
}tree[1000010];
__int64 num[100010];
void pushdown(int len,int i)
{
if(tree[i].lazy)
{
tree[i*2].lazy+=tree[i].lazy;
tree[i*2+1].lazy+=tree[i].lazy;
tree[i*2].sum+=tree[i].lazy*(len-(len/2));
tree[i*2+1].sum+=tree[i].lazy*(len/2);
tree[i].lazy=0;
}
}
void build(int l,int r,int i)
{
tree[i].left=l;
tree[i].right=r;
tree[i].lazy=0;
if(l==r)
{
tree[i].sum=num[l];
}
else
{
int mid=(l+r)/2;
build(l,mid,i*2);
build(mid+1,r,i*2+1);
tree[i].sum=tree[i*2].sum+tree[i*2+1].sum;
}
}
void update(int l,int r,__int64 c,int i)
{
int mid=(tree[i].right+tree[i].left)/2;
if(tree[i].left>=l&&tree[i].right<=r)
{
tree[i].lazy+=c;
tree[i].sum+=c*(tree[i].right-tree[i].left+1);
return;
}
pushdown(tree[i].right-tree[i].left+1,i);
if(l<=mid)
{
update(l,r,c,i*2);
}
if(mid<r)
{
update(l,r,c,i*2+1);
}
tree[i].sum=tree[i*2].sum+tree[i*2+1].sum;
}
__int64 query(int l,int r,int i)
{
int mid=(tree[i].left+tree[i].right)/2;
__int64 ans=0;
if(tree[i].left>=l&&tree[i].right<=r)
{
return tree[i].sum;
}
pushdown(tree[i].right-tree[i].left+1,i);
if(l<=mid)
{
ans+=query(l,r,i*2);
}
if(r>mid)
{
ans+=query(l,r,i*2+1);
}
tree[i].sum=tree[i*2].sum+tree[i*2+1].sum;
return ans;
}
int main()
{
int i;
int a,b,n,m;
__int64 d;
char ch[10];
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=n;i++)
scanf("%I64d",&num[i]);
build(1,n,1);
for(i=0;i<m;i++)
{
scanf("%s",ch);
if(ch[0]=='Q')
{
scanf("%d%d",&a,&b);
printf("%I64d\n",query(a,b,1));
}
else
{
scanf("%d%d%I64d",&a,&b,&d);
update(a,b,d,1);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: