您的位置:首页 > 其它

HDU1069 Monkey and Banana(dp动态规划,最长非递减子序列变形题)

2015-08-24 13:16 561 查看


Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9861 Accepted Submission(s): 5126



Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0


Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


Source

University of Ulm Local Contest 1996

题目大意:

给定一些长方体的长宽高,求这些长方体最高能叠多高,任意长方体都可以用无限次,但是必须要求下面的长方体长和宽要大于上面长方体的长和宽。

解题思路:

这题用到dp最长非递减子序列的思想,我们知道最长非递减子序列的状态转移方程为dp[i] = max(dp[j] + 1,dp[i]) (0<=j<i<=n),再看这题就很容易写出dp[i] = max(dp[j] + a[i],dp[i])这个方程了。动态规划还是得多练,多练才能熟悉。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

const int maxn = 10001;
struct point
{
int x;
int y;
int z;
}p[maxn*6];

int dp[maxn*6];

const int inf = 0x3f3f3f3f;

bool cmp(struct point a,struct point b)
{
return a.x * a.y < b.x * b.y;
}

int main()
{
int m;
int i,j;
int cnt;
int cnt1 = 0;
//freopen("1.txt","r",stdin);
while(scanf("%d",&m) != EOF && m)
{
int aa,bb,cc;
cnt = 0;
for(i=0;i<m;i++)
{
scanf("%d%d%d",&aa,&bb,&cc);
p[cnt].x = aa,p[cnt].y = bb,p[cnt].z = cc;
p[cnt+1].x = aa,p[cnt+1].y = cc,p[cnt+1].z = bb;
p[cnt+2].x = bb,p[cnt+2].y = aa,p[cnt+2].z = cc;
p[cnt+3].x = bb,p[cnt+3].y = cc,p[cnt+3].z = aa;
p[cnt+4].x = cc,p[cnt+4].y = aa,p[cnt+4].z = bb;
p[cnt+5].x = cc,p[cnt+5].y = bb,p[cnt+5].z = aa;
cnt+=6;
}
sort(p,p+cnt,cmp);
/*for(i=0;i<cnt;i++)
{
cout<<p[i].x<<" "<<p[i].y<<" "<<p[i].z<<endl;
}*/
memset(dp,0,sizeof(dp));
for(i=0;i<cnt;i++)
{
dp[i] = p[i].z;
}
int Max = -inf;
for(i=0;i<cnt;i++)
{
for(j=0;j<i;j++)
{
if(p[j].x < p[i].x && p[j].y < p[i].y && dp[j] + p[i].z > dp[i])
{
dp[i] = dp[j] + p[i].z;
//cout<<dp[i]<<endl;
}
}
}
Max = dp[cnt-1];
for(i=0;i<cnt;i++)
{
if(dp[i] > Max)
{
Max = dp[i];
}
}
printf("Case %d: maximum height = %d\n",++cnt1,Max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: