您的位置:首页 > 其它

hdu--5137

2015-08-24 10:59 239 查看

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1045 Accepted Submission(s): 362



[align=left]Problem Description[/align]
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you."
or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.

[align=left]Input[/align]
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.

[align=left]Output[/align]
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.

[align=left]Sample Input[/align]

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0


[align=left]Sample Output[/align]

50
Inf


这道题考查的是:最短路径+枚举。从2到n-1,分别删除一个人,求出最短路径,然后求出最大值,如果最大值大于等于“无穷大”,说明Boss Liu不能成功的将孩子送到中学,那么只要输出Inf就可以了。否则输出刚才所求的最大值,即为当我们做的最好的时候,Boss Liu需要花费的金钱。
代码如下:
#include<stdio.h>
#include<string.h>
#define M 0x3f3f3f3f
int n,m;
int vist[35];
int d[35];
int mark[35][35];
void Dikj(int sx)
{
memset(d,0x3f,sizeof(d));
memset(vist,0,sizeof(vist));
d[1]=0;vist[sx]=1;
while(true)
{
int v=-1;
for(int i=1;i<=n;i++)
{
if(!vist[i]&&(v==-1||d[v]>d[i]))v=i;
}
if(v==-1)break;
vist[v]=1;
for(int j=1;j<=n;j++)
{
if((d[j]>d[v]+mark[v][j])&&!vist[j])
d[j]=d[v]+mark[v][j];
}
}
}
int main()
{
int a,b,c;
while(scanf("%d%d",&n,&m),n|m)
{
memset(mark,0x3f,sizeof(mark));
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&a,&b,&c);
mark[a][b]=c;
mark[b][a]=c;
}
int ans=0;
for(int i=2;i<n;i++)
{
Dikj(i);
if(ans<d
)ans=d
;
}//枚举每一种情况
if(ans>=M)printf("Inf\n");
else printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: