您的位置:首页 > 大数据 > 人工智能

POJ--1995--Raising Modulo Numbers

2015-08-24 10:30 477 查看
Raising Modulo Numbers

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 5509Accepted: 3192
Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment
was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBifrom all players
including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input
3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output
2
13195
13

思路;题目大意是给你N组数,然后N租a^b相加最后对M进行取余操作,运用快速幂可以很快搞定这道题。
注意:sum不能过大,每次求完记得取余,底数也不能过大。
ac代码:
#include<stdio.h>
int M;
int fun(int a,int b){
	int ans=1;
	a=a%M;//底数可能会很大,既然是取余,所以可以把a直接取余,最终结果一样. 
	while(b){
			if(b%2)
		ans=(ans*a)%M;
		a=(a*a)%M;
		b/=2;
	}
	return ans;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int n;
		scanf("%d%d",&M,&n);
		int sum=0;
		while(n--){
			int a,b;
			scanf("%d%d",&a,&b);
			sum+=fun(a,b);//求的是多个a^b的和的模; 
		}
		printf("%d\n",sum%M);//最后还需要取余一次。 
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: