您的位置:首页 > 其它

hdu-1541-Stars (树状数组)

2015-08-24 10:02 337 查看
[align=left]Problem Description[/align]
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For
example, look at the map shown on the figure above. Level of the star
number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2
and 4). And the levels of the stars numbered by 2 and 4 are 1. At this
map there are only one star of the level 0, two stars of the level 1,
one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

[align=left]Input[/align]
The
first line of the input file contains a number of stars N
(1<=N<=15000). The following N lines describe coordinates of stars
(two integers X and Y per line separated by a space,
0<=X,Y<=32000). There can be only one star at one point of the
plane. Stars are listed in ascending order of Y coordinate. Stars with
equal Y coordinates are listed in ascending order of X coordinate.

[align=left]Output[/align]
The
output should contain N lines, one number per line. The first line
contains amount of stars of the level 0, the second does amount of stars
of the level 1 and so on, the last line contains amount of stars of the
level N-1.

[align=left]Sample Input[/align]

5
1 1
5 1

7 1
3 3

5 5

[align=left]Sample Output[/align]

1
2
1

1
0

[align=left]Source[/align]
Ural Collegiate Programming Contest 1999

[align=left]Recommend[/align]
LL

#include <stdio.h>
#include <string.h>
int c[32005],level[32005],n;
int lowbit(int x)
{
return x&(-x);
}
int sum(int x)
{
int sum=0;
while(x>0)
{

sum=sum+c[x];
x=x-lowbit(x);
}
return sum;
}
void add(int i,int x)
{
while(i<32005)//要保证在最大坐标范围内
{
c[i]=c[i]+x;
i=i+lowbit(i);
}
}
int main()
{
int x;
int y;
while(scanf("%d",&n)!=EOF&&n)
{
memset(level,0,sizeof(level));
memset(c,0,sizeof(c));
for(int i=1; i<=n; i++)
{
scanf("%d%d",&x,&y);
level[sum(++x)]+=1;//,要在他自身之前,所以在add以前
add(x,1);//当x等于0的时候,会陷入死循环,所以横坐标整体向右移一位,结果不变!
}
for(int i=0; i<n; i++)
{
printf("%d\n",level[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: