您的位置:首页 > 其它

HDOJ 3665 Seaside(最短路径,dijkstra算法)

2015-08-24 09:49 417 查看

Seaside

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1373 Accepted Submission(s): 988



Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting
them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest
way.


Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1)
and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi,
which means that the distance between the i-th town and the SMi town is LMi.


Output
Each case takes one line, print the shortest length that XiaoY reach seaside.


Sample Input
5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1




Sample Output
2





按照题意的输入建图即可,最短路水题。


dijkstra算法,代码如下:


#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
#define maxn 12
int map[maxn][maxn],dis[maxn],n;

void dijkstar()
{
	int visit[maxn];
	int i,j,min,next=0;
	for(i=0;i<n;++i)
	{
		dis[i]=map[0][i];
		visit[i]=0;
	}
	visit[0]=1;
	for(i=1;i<n;++i)
	{
		min=INF;
		for(j=0;j<n;++j)
		{
			if(!visit[j]&&min>dis[j])
			{
				next=j;
				min=dis[j];
			}
		}
		visit[next]=1;
		for(j=0;j<n;++j)
		{
			if(!visit[j]&&dis[j]>dis[next]+map[next][j])
			   dis[j]=dis[next]+map[next][j];
		}
	}
}

int main()
{
	int i,j,end[10],num,d,k,sea,place;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
			{
				if(i==j)
				  map[i][j]=0;
				else
				  map[i][j]=INF;
			}
		}
		k=0;
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&num,&sea);
			if(sea)
			  end[k++]=i;//将在海边小镇存入数组 
			for(j=0;j<num;++j)
		    {
		    	scanf("%d%d",&place,&d);
		    	if(map[i][place]>d)
		    	   map[i][place]=d;//注意是单向图 
		    }
		}
		dijkstar();
		int ans=INF;
		for(i=0;i<k;++i)//找到到海边最短的路径权值 
		{
			if(dis[end[i]]<ans)
			   ans=dis[end[i]];
		}
		printf("%d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: