您的位置:首页 > 其它

HDOJ 3665 Seaside(最短路--floyd)

2015-08-23 23:05 267 查看

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1368    Accepted Submission(s): 983


[align=left]Problem Description[/align]
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed
that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

[align=left]Input[/align]
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines
followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that
the distance between the i-th town and the SMi town is LMi.
 

[align=left]Output[/align]
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

[align=left]Sample Input[/align]

5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1

 

[align=left]Sample Output[/align]

2

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define  MAXN 1010
#define INF 0xfffffff
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
using namespace std;
int pri[MAXN][MAXN];
int num[MAXN];
int main()
{
int n;
int i,j,m,a,c,k;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
for(j=0;j<n;j++)
pri[i][j]=i==j?0:INF;
for(i=0;i<n;i++)
{
scanf("%d%d",&m,&num[i]);
for(j=0;j<m;j++)
{
scanf("%d%d",&a,&c);
if(pri[i][a]>c)
pri[i][a]=pri[a][i]=c;
}
}
for(k=0;k<n;k++)
for(i=0;i<n;i++)
for(j=0;j<n;j++)
pri[i][j]=min(pri[i][j],pri[i][k]+pri[k][j]);
int mi=INF;
for(i=1;i<n;i++)
{
if(num[i])
{
mi=min(mi,pri[0][i]);
}
}
printf("%d\n",mi);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: