您的位置:首页 > 其它

How Many Maos Does the Guanxi Worth

2015-08-23 21:54 253 查看
Problem Description

"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you."
or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance,
someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster.
In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that
if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will
be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you
can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely
succeed.

Input

There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss
Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.

Output

For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.

Sample Input



4 5

1 2 3

1 3 7

1 4 50

2 3 4

3 4 2

3 2

1 2 30

2 3 10

0 0

Sample Output



50

Inf

题解:1代表老板刘,n代表校长。在给出的n个人中,我可以说服其中的任何一个人(除了老板刘和校长)拒绝提供帮助,最后问老板刘是否能将它的孩子送进中学?

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f
#define MIN(a,b) (a<b?a:b)
#define MAX(a,b)  (a>b?a:b)
int n,m,k;
int cost[1100][1100];
int po[1100][1100];
int d[1100];
int mark[1100];
int dijkstra()
{
int i,j,u,v;
for(i=1;i<=n;i++)
{
d[i]=INF;
mark[i]=0;
}
d[1]=0;
while(1)
{
v=-1;
for(u=1;u<=n;u++)
{
if(mark[u]==0&&(v==-1||d[u]<d[v]))
v=u;
}
if(v==-1)
break;
mark[v]=1;
for(u=1;u<=n;u++)
{
if(mark[u]==0)
d[u]=MIN(d[u],d[v]+cost[v][u]);
}
}
return d
;
}
int main()
{
while(scanf("%d%d",&n,&m),n||m)
{
int i,j,a,b,c,flag=0,t;
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
cost[i][j]=INF;
po[i][j]=INF;
}

for(i=1;i<=m;i++)
{
scanf("%d%d%d",&a,&b,&c);
if(c<cost[a][b])
{
cost[a][b]=cost[b][a]=c;
po[a][b]=po[b][a]=c;
}

}
t=dijkstra();//
for(i=2;i<n;i++)//
{
for(j=1;j<=n;j++)
cost[i][j]=cost[j][i]=INF;//某个人拒绝帮助,那与这个人有关系的人距离设为无穷大。
int f;
f=dijkstra();
t=MAX(f,t);
for( k=1;k<=n;k++)
cost[i][k]=cost[k][i]=po[i][k]; //恢复原来的距离
}
if(t!=INF)
printf("%d\n",t);
else
printf("Inf\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: