您的位置:首页 > 其它

seaside

2015-08-23 21:39 316 查看
Problem Description

XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed
that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

Input

There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then
Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S[sub]Mi[/sub] and L[sub]Mi[/sub], which means
that the distance between the i-th town and the S[sub]Mi[/sub] town is L[sub]Mi[/sub].

Output

Each case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input

5

1 0

1 1

2 0

2 3

3 1

1 1

4 100

0 1

0 1

Sample Output

2

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f
#define MIN(a,b) a<b?a:b
int mark[2000];
int d[2000];
int map[2000][2000];
int a[1000];
int n;
void dijkstra(int s)
{
int i,j,u,v;
for(i=0;i<n;i++)
{
d[i]=INF;
mark[i]=0;
}

d[0]=0;
while(1)
{
v=-1;
for(u=0;u<n;u++)
{
if(mark[u]==0&&(v==-1||d[u]<d[v]))
v=u;
}
if(v==-1)
break;
mark[v]=1;
for(u=0;u<n;u++)
{
//if(mark[u]==0)
d[u]=MIN(d[u],d[v]+map[v][u]);
}

}

}
int main()
{
int m,sea,i,j,dis,p;
while(scanf("%d",&n)!=EOF)
{
int k=0;
memset(mark,0,sizeof(0));
//	for(i=0;i<n;i++)
//	   d[i]=INF;
for(i=0;i<n;i++)
for(j=0;j<n;j++)
map[i][j]=INF;
for(i=0;i<n;i++)
{
scanf("%d%d",&m,&sea);
if(m!=0)
{
while(m--)
{
scanf("%d%d",&p,&dis);
map[i][p]=dis;
map[p][i]=dis;
}

}
if(sea==1)
{
a[k++]=i;//<span style="color:#ff0000;">这个数组用来存与海相邻的城市!!
</span>		  }
}
dijkstra(0);
int min=INF;
for(i=0;i<k;i++)
{
if(d[a[i]]<min)
min=d[a[i]];

}
printf("%d\n",min);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: