您的位置:首页 > 其它

九度oj 1136

2015-08-23 21:12 344 查看
Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, ... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively
and this pattern has continued.



You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

输入:

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

输出:

For each point in the input, write the number written at that point or write No Number if there is none.

样例输入:
3
4 2
6 6
3 4


样例输出:
6
12
No Number


来源:
2008年北京大学软件所计算机研究生机试真题

#include<iostream>
using namespace std;
int main(){
int n;
while(cin>>n){
int x,y;
for(int i=0;i<n;i++){
cin>>x>>y;
if(x==y||x-y==2){
if(x%2==0)
cout<<x+y<<endl;
else
cout<<x+y-1<<endl;
}
else
cout<<"No Number"<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: