您的位置:首页 > 其它

杭电acm 1072 Nightmare

2015-08-23 19:40 465 查看

杭电acm 1072 Nightmare

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1072

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

1. We can assume the labyrinth is a 2 array.

2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.

3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.

4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.

5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.

6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.

There are five integers which indicate the different type of area in the labyrinth:

0: The area is a wall, Ignatius should not walk on it.

1: The area contains nothing, Ignatius can walk on it.

2: Ignatius’ start position, Ignatius starts his escape from this position.

3: The exit of the labyrinth, Ignatius’ target position.

4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1


Sample Output

4
-1
13


这是一道BFS题目,题目不是很难,这里直接贴上代码:

#include <iostream>
#include <queue>
using namespace std;
const int Max=99999;
int arr[21][21],N,M;
int st[10][10];   //记录到每个位置时剩余时间
int Move[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
typedef struct Go{
int X;
int Y;
int Time;
int numb;
};
Go Now,Ip;
queue<Go> Q;
int Minnumb;
int main()
{
int T;
cin>>T;
for(int m=1;m<=T;m++)
{
cin>>N>>M;
Minnumb=Max;
memset(arr,0,sizeof(arr));
memset(st,0,sizeof(st));
for(int i=1;i<=N;i++)
{
for(int j=1;j<=M;j++)
{
cin>>arr[i][j];
if(arr[i][j]==2)
{
Now.X=i;
Now.Y=j;
Now.Time=6;
Now.numb=0;
Q.push(Now);
}
}
}
Now=Q.front();
arr[Now.X][Now.Y]=0;  //入口为0
while(!Q.empty())
{
Now=Q.front();
Q.pop();
if(Now.Time==0)
continue;
if(arr[Now.X][Now.Y]==4)
Now.Time=6;

if(arr[Now.X][Now.Y]==3)
{
if(Now.numb<Minnumb)
Minnumb=Now.numb;
continue;
}
//printf("%d %d %d %d\n",Now.X,Now.Y,Now.numb,Now.Time);
for(int i=0;i<4;i++)
{
Ip.X=Now.X+Move[i][0];
Ip.Y=Now.Y+Move[i][1];
Ip.Time=Now.Time-1;
Ip.numb=Now.numb+1;
if(arr[Ip.X][Ip.Y]!=0  && Ip.Time > st[Ip.X][Ip.Y])
{
st[Ip.X][Ip.Y]= Ip.Time ;
Q.push(Ip);
}
}
}
if(Minnumb==Max)
cout<<-1<<endl;
else
cout<<Minnumb<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: