您的位置:首页 > 其它

hdoj 5137 How Many Maos Does the Guanxi Worth【最短路 Floyd】

2015-08-23 14:24 579 查看


How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1028 Accepted Submission(s): 350



Problem Description

"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them
is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.

Input

There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.

Output

For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.

Sample Input

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0


Sample Output

50
Inf


Source

2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)

//题目求的是最短路径中最长的那条可以是无穷大.
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int dis[33][33],map[33][33];
int n,m;
int  floyd(int x)
{
int i,j,k;
for( i = 1; i <= n; i++)
for( j = 1; j <= n; j++)
if(i == x||j == x)
dis[i][j] = dis[j][i] = INF;
else
dis[i][j] = dis[j][i] = map[i][j];
for( k = 1; k <= n; k++)
for( i = 1; i <= n; i++)
for( j = 1; j <= n ; j++)
dis[i][j] = min(dis[i][j], dis[i][k]+dis[k][j]);
return dis[1]
;
}
int main()
{
int i,j,k,a,b,c;
while(scanf("%d%d",&n,&m)!=EOF,n|m)//输入n个人,m个关系
{
for(i = 1; i <= n; i++)
for(j = 1; j <= n ;j++)
map[i][j] = (i==j?0:INF);//赋值自身花费0,不同点无穷大.
while(m--)
{
scanf("%d%d%d",&a,&b,&c);//输入两点和边的权值
if(map[a][b]>c)// 如果 INF>c
map[a][b] = map[b][a] = c;
}/*截止目前构建好了图.让人头疼的是怎么去掉关键节点.
我采用的是Floyd + 一一对比 取得最优解,
按第一组数据吧:先让12/21距离为INF,Floyd走一遍求出一个ans.
第二次13/31距离INF,Floyd走一遍在求出一个ans,取大的ans即为所求.
因为题目又没让求去掉的是哪个点,所以比大小就好了*/
int ans = 0;
for(i = 2; i < n; i++)//1是起点.n是终点,故不在此循环
ans = max(ans,floyd(i));
if(ans!=INF)
printf("%d\n",ans);
else
puts("Inf");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: