您的位置:首页 > 其它

HDU 1496 Equations(哈希打表+二分暴力)

2015-08-23 10:29 387 查看

Equations

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6580 Accepted Submission(s): 2648



[align=left]Problem Description[/align]
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0

a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

[align=left]Input[/align]
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.

End of file.

[align=left]Output[/align]
For each test case, output a single line containing the number of the solutions.

[align=left]Sample Input[/align]

1 2 3 -4
1 1 1 1


[align=left]Sample Output[/align]

39088
0
#include <iostream>
#include <cstdio>
#include <math.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iomanip>
#include <stdlib.h>
using namespace std;
const int N=2000000+20;
const int M=1000000+20;
int ha
;
int main(){
int a,b,c,d,i,j,sum,x;
while(scanf("%d%d%d%d",&a,&b,&c,&d)==4){
sum=0;
memset(ha,0,sizeof(ha));
if((a>0&&b>0&&c>0&d>0)||(a<0&&b<0&&c<0&d<0))
{
printf("0\n");
continue;
}
for(i=1;i<=100;i++)
for(j=1;j<=100;j++)
ha[a*i*i+b*j*j+M]++;

for(i=1;i<=100;i++)
for(j=1;j<=100;j++)
sum+=ha[-c*i*i-d*j*j+M];
printf("%d\n",sum*16);
}
return 0;
}

/*  四循环改成三循环 还是超时
#include <iostream>
#include <cstdio>
#include <math.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iomanip>
#include <stdlib.h>
#include <set>
using namespace std;
const int N=1000000+10;
int a
;
int main(){
int a,b,c,d,i,j,k,z,sum,x;
while(scanf("%d%d%d%d",&a,&b,&c,&d)==4){
sum=0;
if((a>0&&b>0&&c>0&d>0)||(a<0&&b<0&&c<0&d<0))
{
printf("0\n");
continue;
}
for(i=1;i<=100;i++)
for(j=1;j<=100;j++)
for(k=1;k<=100;k++){
x=sqrt((a*i*i+b*j*j+c*k*k)/(-d));
if(x>0&&x<=100&&a*i*i+b*j*j+c*k*k+d*x*x==0)
sum+=16;
}
printf("%d\n",sum);
}
return 0;
}
*/


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: