您的位置:首页 > 其它

BestCoder Round #52 (div.2) 1001 Victor and Machine

2015-08-22 19:29 543 查看
Problem Description

Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball everywww
seconds. However, the machine has some flaws, every time after xxx
seconds of process the machine has to turn off for yyy
seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.

Now, at the 000
second, the machine opens for the first time. Victor wants to know when the
nnn-th
ball will be popped out. Could you tell him?

Input

The input contains several test cases, at most 100100100
cases.

Each line has four integers xxx,yyy,www
and nnn.
Their meanings are shown above。

1≤x,y,w,n≤1001\leq x,y,w,n\leq 1001≤x,y,w,n≤100.

Output

For each test case, you should output a line contains a number indicates the time when thennn-th
ball will be popped out.

Sample Input

2 3 3 3
98 76 54 32
10 9 8 100


Sample Output

10
2664
939


#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int x,y,w,n;
while(cin>>x>>y>>w>>n)
{
int k = 1;
int i;
int sum = 0;
for(i=1;;i++)
{
if(k == n)
{
printf("%d\n",i-1);
break;
}
else
{
if(i%(x+y) == 0)
{
k++;
sum = 0;
}
else if(i % (x+y) <= x)
sum++;
if(sum == w)
{
k++;
sum = 0;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: