您的位置:首页 > 其它

HDU 1033.Edge【模拟】【8月22】

2015-08-22 18:44 267 查看
Edge

Problem Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its
initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated
by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in
a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming
90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately
after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto".
Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge
and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.



Sample Input

V
AVV


Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage


一个点,初始坐标是(300,420),现在已经走到了(310,420),A表示右转,V表示左转。每次转弯后走10个单位长度。给定‘A’、‘V’的字符串,输出点的轨迹。具体格式看样例。直接模拟,代码如下:

#include<cstdio>
#include<cstring>
char s[105];
int main(){
while(scanf("%s",s)!=EOF){
printf("300 420 moveto\n310 420 lineto\n");
int dir=3,x=310,y=420;//dir记录方向
for(int i=0;i<strlen(s);i++){
s[i]=='A'?dir-=1:dir=(dir+1)%4;
if(dir==-1) dir=3;
switch(dir){//0为向上,1为向左,2为向下,3为向右
case 0:y+=10;break;
case 1:x-=10;break;
case 2:y-=10;break;
case 3:x+=10;break;
}
printf("%d %d lineto\n",x,y);
}
printf("stroke\nshowpage\n");
}
return 0;
}



还是比较水的一道题,关键是这题目内容太坑人了!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: