您的位置:首页 > 其它

HDOJ--5137--How Many Maos Does the Guanxi Worth

2015-08-22 18:23 323 查看


How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1021 Accepted Submission(s): 345



Problem Description

"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them
is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.



Input

There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.



Output

For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.



Sample Input

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0




Sample Output

50
Inf



题意:这道题的大概意思就是说有个老板想托关系,让孩子上个好一点的学校。你非常恨这种人,所以你就去劝说老板关系网的某个人让他拒绝一切请求(也就是说这个点是断点)然后考虑一下怎么样老板能花更多的钱。但是你在让老板花钱的同时,老板也希望自己的钱能花的少一些。
思路:大体上还是最短路的求法。去掉某个点然后求最短路,遍历去掉的点,去最短路当中的最大值。
AC代码:
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int dis[50][50],n,m,ans,map[50][50];
void init(){
	memset(map,INF,sizeof(map));
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
			if(i==j)
				map[i][j]=map[j][i]=0;
}
void copy(){
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
			dis[i][j]=map[i][j];
}
void floyd(){
	int i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			if(dis[i][k]!=INF){
				for(j=1;j<=n;j++)
					if(dis[i][j]>dis[i][k]+dis[k][j])
						dis[i][j]=dis[i][k]+dis[k][j];
			}
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF&&n!=0&&m!=0){
		init();
		while(m--){
			int a,b,cost;
			scanf("%d%d%d",&a,&b,&cost);
			if(map[a][b]>cost)
				map[a][b]=map[b][a]=cost;
		}
		 ans=-1;
		for(int i=2;i<n;i++){
			copy();
			for(int j=1;j<=n;j++)
				dis[i][j]=dis[j][i]=INF;
			floyd();
			if(ans<dis[1]
)
				ans=dis[1]
;
			if(ans==INF)
				break;
		}
		if(ans==INF)
			printf("Inf\n");
		else
			printf("%d\n",ans);	
			
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: