您的位置:首页 > 其它

hdu5410 CRB and His Birthday

2015-08-22 17:22 204 查看
Problem Description
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.

She went to the nearest shop with M
Won(currency unit).

At the shop, there are N
kinds of presents.

It costs Wi
Won to buy one present of i-th
kind. (So it costs k
× Wi
Won to buy k
of them.)

But as the counter of the shop is her friend, the counter will give
Ai × x + Bi
candies if she buys x(x>0)
presents of i-th
kind.

She wants to receive maximum candies. Your task is to help her.

1 ≤ T
≤ 20

1 ≤ M
≤ 2000

1 ≤ N
≤ 1000

0 ≤ Ai, Bi
≤ 2000

1 ≤ Wi
≤ 2000



Input
There are multiple test cases. The first line of input contains an integer
T,
indicating the number of test cases. For each test case:

The first line contains two integers M
and N.

Then N
lines follow, i-th
line contains three space separated integers Wi,
Ai
and Bi.



Output
For each test case, output the maximum candies she can gain.


Sample Input
1
100 2
10 2 1
20 1 1




Sample Output
21
HintCRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.


完全背包变形

#include<stdio.h>

#include<string.h>

#include<iostream>

using namespace std;

#define N 1100

#define M 2100

int dp[M];

int main(){

int t;

int n;

int m;

int wi,ai,bi;

scanf("%d",&t);

while(t--){

scanf("%d%d",&m,&n);

memset(dp,0,sizeof(dp));

for(int i=1;i<=n;i++){

scanf("%d%d%d",&wi,&ai,&bi);

for(int j=m;j>=wi;j--){

if(dp[j]<dp[j-wi]+ai+bi){

dp[j]=dp[j-wi]+ai+bi;

}

}

for(int j=wi;j<=m;j++){//优化

if(dp[j]<dp[j-wi]+ai){

dp[j]=dp[j-wi]+ai;

}

}

}

printf("%d\n",dp[m]);

}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: