您的位置:首页 > 其它

HDU 1028 Ignatius and the Princess III

2015-08-22 16:28 281 查看
A - Ignatius and the Princess III
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
SubmitStatus

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+...+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20


Sample Output

5
42
627


看上去貌似是考母函数之类的一道题,但是到现在并没有掌握母函数的知识,在这里占个位,以后补充。

这题的意思是问,拆分一个整数一共有多少种方法。

我的做法是 DP。

可得到下面三个状态转移方程。

dp[i][j]表示为用最大不超过j的整数去合并为i.

if(i<j)

dp[i][j]=dp[i][i];

else if(i>j)

dp[i][j]=dp[i-j][j]+dp[i][j-1];

else

dp[i][j]=dp[i][j-1]+1;

先DP打表,然后输出即可。

#include <stdio.h>
#define N 125
int n,dp

;
int main()
{
for(int i=1;i<=120;i++)
dp[i][1]=1;
for(int j=1;j<=120;j++)
dp[1][j]=1;
for(int i=1;i<=120;i++)
for(int j=1;j<=120;j++)
if(i<j)
dp[i][j]=dp[i][i];
else if(i>j)
dp[i][j]=dp[i-j][j]+dp[i][j-1];
else
dp[i][j]=dp[i][j-1]+1;
while(scanf("%d",&n)>0)
printf("%d\n",dp

);
return 0;
}


在DISCUSS里看到还有大牛用完全背包做的。

#include<cstdio>
#define N 125
int n,dp
;
int main()
{
dp [0] = 1;
for(int i = 1;i<=120;i++)
for(int j = i;j<=120;j++)
dp[j]+=dp[j-i];
while(scanf("%d",&n)>0)
printf("%d\n",dp
);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: